Loyola University Chicago

Information Technology Services

MacOS Catalina 10.15

Mac Operating System (MacOS) Update:

MacOS, Version Catalina 10.15 was released on October 7, 2019.  This new MacOS version requires all applications to only use 64-bit software going forward and all older application versions will no longer function properly.  At this time, until it is fully tested with our standard applications, Information Technology Services (ITS) will not be upgrading to the new release at this time.  

Recommendation

PLEASE NOTE, if you have a personal Apple device and are thinking of upgrading, ITS recommends you do not upgrade until you have confirmed that all applications you intend to use on your Apple device are 64-bit compatible.  Apple provides instructions for checking if an application is 32-bit or 64-bit here https://support.apple.com/en-us/HT208436

If you have OS X 10.12 (Sierra) or an older version, we strongly recommend that you upgrade to at least macOS 10.13 (High Sierra).  Apple will most likely stop providing software updates or critical security updates for OS X 10.12 and older versions soon. High Sierra can be downloaded from here: https://support.apple.com/kb/DL1970?locale=en_US

Please revisit this page periodically for updates.  You can contact the Loyola Service Desk for assistance via email at ITSServiceDesk@luc.edu or by calling 773.508.4ITS.